Answer of your leaving message
All of a sudden the blue light is on and else the Cam is dead. After Plug in /unplugging from power, the blue light is on but the Cam does not rotate and the green light stays off. No beeps no movement nothing. The App shows the Cam is Offline! Resetting did not change anything. Also tried to use the WPS connection, no action. I also removed the SD Card and tested then reinserted the SD Card and tested, but still nothing happens. Either the FW is corrupt or it is a hardware issue. What can I do now?

2018-01-22 13:13:33****************************************
Thanks for the instructions. I finally got it to work with the manual FW rebuild. Great job!

by Tarek El Nayal


Dear Tarek, thank you for contacting.

Firmware update/rewrite manually :

A. Please must use this tool to format the SD card on PC
https://www.sdcard.org/downloads/formatter_4/index.html

After checking/exchanging the SD card and AC/USB cable to cross check, if it is still not working :

B.
Rebuild the firmware from the external SD card :
This is a manual re-build firmware procedure for your reference (recovery and cure rate is more than 90% )

Download file
https://www.dropbox.com/s/nkeywybjwcf12ej/iCam.rar?dl=0 [PC] C.
- Uncompress/unzip it to ROOT directory of a MicroSD card [PC->SD]
- Insert the card to iCam or iBabi
- Plug power cord of it. CAM will auto detect the codes in the Card
to do the update ( blue light is on ) D. Auto motor calibration/rotation (About 40~50 seconds)
- Wait till front blue led is blinking. (About 2-3 minutes)
- Unplug power cord
- Take card out.
- Plug power cord again and the blue led will keep blink ( waiting for installation )

Installation: https://www.youtube.com/watch?v=V-j_OzXsANo / If you are successful, please erase the card for normal use.

PS – this is what you see during the process
Insert the card with unzipped files
Plug in power
Short beep ( camera detect and read the files ) in 5 seconds
After about 40 seconds Two short beeps ( writing complete )
Blue and Green lights blinking – done ( wrote in )
Unplug the power
Remove the SD and erase it