Answer of your leaving message
Model: iCamPro FHD; was working on Friday 6/April, turned 'offline', will not turn 'online' on Monday 9/4.
Nothing has changed in the network, and 2 other Amayrllo cameras are connected okay to the network.
Please advise.


by Barry


Dear Barry, thank you for contacting.
First, please kindly check if the privacy is on
If the blue light is still on, you may try hardware reset and reinstall to see if it is recovered.
RESET : https://www.youtube.com/watch?v=VNvftkbS__c
INSTALL : https://www.youtube.com/watch?v=IR_m6dlKmAo / https://www.youtube.com/watch?v=V-j_OzXsANo

If the problem is still:

1. Exchange the AC and USB cable to try
2. Exchange the SD card to try

If the problem is still:
A. Please must use this tool to format the SD card on PC ( check health )
https://www.sdcard.org/downloads/formatter_4/index.html

Rebuild the firmware from the external SD card :

B. Download file : https://www.dropbox.com/s/mhl2l30tuxb0d6b/iCAM%20Pro_v421.rar?dl=0 [ to PC ]
C.
- Uncompress/unzip it to root directory of a MicroSD card [PC->SD]
- Insert the card to the camera
- Plug power cord of it. CAM will auto detect the codes in the Card to
do the update ( blue light is on )
- Wait till front blue and green led is blinking with 2 beeps.
(About 2-3 minutes)
- Unplug power cord
- Take card out.
- Plug power cord again and the blue led will keep blinking
( waiting for installation )

Installation: https://www.youtube.com/watch?v=V-j_OzXsANo / If you are successful, please erase the card for normal use.

PS – this is what you see during the process
Insert the card with unzipped files
Plug in power, should hear short beep ( camera detect and read the files ) in 5 seconds
After about 40 seconds Two short beeps ( writing complete )
Blue and Green lights blinking – done ( wrote in ) Unplug the power Remove the SD and erase it for future use